9 Replies Latest reply on Sep 19, 2017 10:13 AM by wroot

    Openfire + Spark + Xabber configuration

    Mihail Zinchenko

      Hi everybody. At first I want to say "Thank you so much!" to developers of Openfire and Spark.

      The second I want to ask community about help with my task.

      I need to install and configure XMPP server as corporative chat for my company so I decided to pick Openfire and Spark combination. In addition there are is a couple workers with Android smartphones which should be connected to XMPP server to via 3G\4G.

       

      I've done such steeps:

      -installed Linux server

      -installed Openfire

      -went to admin console and configured mysql and local hostname and fqdn names. They were the same as server's hostname. Name was something like "lin-test".

      All works fine (server, logs, plug-ins, encryption) inside local network but when I tried to connect clients with Android devices (Xabber) problems started. I forwarded 5222 port through my router and tried to configure mobile xmpp client for using my DDNS address. But it's was impossible to connect from outside using mobile client. There was a record in log file:

      Will not route: Remote domain myddns.afraid.org is not accessible according to our configuration

       

      When I tried co connect from outside using Spark it was successfully connection except I have to remove checkbox "Disable certificate hostname verification" in Spark configuration.

      After that I reconfigured my Openfire server from the beginning and used my DDNS record instead of Linux server hostname. After such manipulations I've got reverse problem: it's becomes possible to connect via Xabber (but encryption should be disabled) from Internet. But clients from local network can't connect without removing checkbox "Disable certificate hostname verification".

       

      So I have 2 questions:

      How to force Xabber work with encryption?

      And how should I configure my router and_or Openfire properly?