AnsweredAssumed Answered

Openfire admin password error occurs when connect Openfire server with MySQL database(import/restored on Cloud SQL using dump)

Question asked by Yassir on Aug 7, 2017
Latest reply on Aug 7, 2017 by Yassir

I have Openfire chat server on Google Compute Engine instance and MySQL database on same instance (on same IP, in case you don't know).

Now I have taken dump of MySQL and import/restored it to Cloud SQL instance. So that, in future multiple Openfire server can access data from same MySQL database.

When I install new Openfire server on another Compute Engine instance and connect MySQL database (which I imported on Cloud SQL instance) using IP, connection with MySQL is Ok but it says my current Openfire admin password is wrong during Openfire setup, even though it is setup.

If I click on 'Skip This Step' and then login on Administration console, its says - "Login failed: make sure your username and password are correct and that you're an admin or moderator."

Let's say

      IP of MySQL installed on Cloud SQL instance:  
of new Openfire installed on Compute Engine:

I have tried following options, but none these worked-

  • Entered Openfire default password 'admin'
  • Entered password of my old Openfire server.
  • Updated plainPassword field of ofUser table in MySQL and tried.
  • Changed fileds in ofProperty table of MySQL and tried.
  • Changed openfire.xml file on Openfire server as per this docs-                                                                                        tion-guide.html