AnsweredAssumed Answered

Can't launch or configure Openfire after installation

Question asked by Mark Bernstein on Jul 26, 2017
Latest reply on Jul 27, 2017 by wroot

Just tried to install and configure Openfire 4.1.5 on a MacOS 10.9.5 system. FWIW, I don't have networking/server training or experience, but want to set up a simple chat server to handle basic chat service for the 25 or so people in my office. It was my understanding that Openfire, with its defaults right out of the box, should be very easy to get up and running. So I figured I'd try it and see what happens.

 

The installation went just fine, but when I first tried to work with it, everything came to a screeching halt. I clicked on the prefpane, and it went through its expected relaunch of System Preferences due to the 32 bit/64 bit thing.  But when the launch window opens, the "Open Admin Console" button is greyed out and unresponsive--and under "Status", Openfire is showing as "Stopped" (see attached screenshot).  I clicked the unlock icon and authenticated, so that's not the problem. When I click on "Start Openfire", it appears to be launching something (the Apple gearwheel spinner appears), but then it stops with no apparent change, in anything. So obviously I'm stuck at this point. To troubleshoot, thinking of old vs. new OS issues, I also tried this with a different Mac running the latest Sierra 10.12.6.  Same exact thing.

 

Am I missing something obvious?   One thing I've thought of is that this could be related to the presence or absence of the right Java software on my system. But I've always found the Java runtime/"machine" stuff to be mysterious and have never paid it any attention (why wouldn't my current Mac, running Sierra have the "right" Java software on it?). And wouldn't Openfire complain with an error message or something, if it detected that no Java was available (or the *wrong* one)?

 

Any help would be MOST appreciated.

 

Mark

Outcomes