5 Replies Latest reply on Jul 27, 2017 8:15 AM by wroot

    Can't launch or configure Openfire after installation

    Mark Bernstein

      Just tried to install and configure Openfire 4.1.5 on a MacOS 10.9.5 system. FWIW, I don't have networking/server training or experience, but want to set up a simple chat server to handle basic chat service for the 25 or so people in my office. It was my understanding that Openfire, with its defaults right out of the box, should be very easy to get up and running. So I figured I'd try it and see what happens.

       

      The installation went just fine, but when I first tried to work with it, everything came to a screeching halt. I clicked on the prefpane, and it went through its expected relaunch of System Preferences due to the 32 bit/64 bit thing.  But when the launch window opens, the "Open Admin Console" button is greyed out and unresponsive--and under "Status", Openfire is showing as "Stopped" (see attached screenshot).  I clicked the unlock icon and authenticated, so that's not the problem. When I click on "Start Openfire", it appears to be launching something (the Apple gearwheel spinner appears), but then it stops with no apparent change, in anything. So obviously I'm stuck at this point. To troubleshoot, thinking of old vs. new OS issues, I also tried this with a different Mac running the latest Sierra 10.12.6.  Same exact thing.

       

      Am I missing something obvious?   One thing I've thought of is that this could be related to the presence or absence of the right Java software on my system. But I've always found the Java runtime/"machine" stuff to be mysterious and have never paid it any attention (why wouldn't my current Mac, running Sierra have the "right" Java software on it?). And wouldn't Openfire complain with an error message or something, if it detected that no Java was available (or the *wrong* one)?

       

      Any help would be MOST appreciated.

       

      Mark

        • Re: Can't launch or configure Openfire after installation
          wroot

          Mark Bernstein wrote:

          why wouldn't my current Mac, running Sierra have the "right" Java software on it?

          Because it's Apple As far as i remember, they hate Java as much as Flash. There could be some limited or outdated or no at all java on your Mac. But as i don't use Macs, can't really suggest the right way to install Oracle's latest Java. You can try finding the logs. Again, not sure where it is installed on macOS. On Linux it is usually in /opt/openfire. Search for the /logs dir and then all.log.

            • Re: Can't launch or configure Openfire after installation
              Mark Bernstein

              Thanks for your suggestion. However, after installing the latest Java, I still can't get Openfire to...do anything.

               

              mb

                  • Re: Can't launch or configure Openfire after installation
                    Mark Bernstein

                    The only log entries or messages I can find in Console that seem to relate to Openfire are these (note that I left out most of the endless repetition of the same message over and over):

                     

                    Jul 27 08:22:12 COMM858876 com.apple.launchd[1] (org.jivesoftware.openfire): Throttling respawn: Will start in 10 seconds

                    . . .  [repeated every ten seconds]

                    Jul 27 09:07:11 COMM858876 com.apple.launchd[1] (org.jivesoftware.openfire): Throttling respawn: Will start in 10 seconds

                    Jul 27 09:07:19 COMM858876 kernel[0]: hfs: unmount initiated on Openfire on device disk2s2

                    Jul 27 09:07:21 COMM858876 com.apple.launchd[1] (org.jivesoftware.openfire): Throttling respawn: Will start in 10 seconds

                    Jul 27 09:07:29 COMM858876 kernel[0]: hfs: mounted Openfire on device disk2s2

                    Jul 27 09:07:29 COMM858876 com.apple.launchd[1] (org.jivesoftware.openfire): Throttling respawn: Will start in 3 seconds

                    Jul 27 09:07:29 COMM858876.local mds[63]: (Normal) Volume: volume:0x7fd0fe0e8000 ********** Bootstrapped Creating a default store:1 SpotLoc:(null) SpotVerLoc:(null) occlude:0 /Volumes/Openfire

                    Jul 27 09:07:32 COMM858876 com.apple.launchd[1] (org.jivesoftware.openfire): Throttling respawn: Will start in 10 seconds

                    Jul 27 09:07:37 COMM858876 kernel[0]: hfs: unmount initiated on Openfire on device disk2s2

                    Jul 27 09:07:42 COMM858876 com.apple.launchd[1] (org.jivesoftware.openfire): Throttling respawn: Will start in 10 seconds

                    . . .  [repeated every ten seconds, endlessly]

                     

                    As long as the computer is running, the "respawn" message pops up every ten seconds, interspersed occasionally by the "mounted" or "unmounted" message.