2 Replies Latest reply on Jul 25, 2017 1:26 AM by Rollan

    Stanza.io with OpenFire 4.1.3

    LeChuck

      I'm trying to connect stanza.io (websocket and bosh) with Openfire 4.1.3 . I'm using the last version of stanza.io and I have diferent problems depending of protocol:

      • bosh: I receive no-authentication. These are the messages interchanged:
        • stanza.io->>>  <body xmlns="http://jabber.org/protocol/httpbind" xmlns:xmpp="urn:xmpp:xbosh" xmpp:version="1.0" to="openopen" xml:lang="en" wait="30" ver="1.6" hold="1" rid="9782020898"/>
        • Openfire<<<-  <body xmlns="http://jabber.org/protocol/httpbind" xmlns:stream="http://etherx.jabber.org/streams" from="openopen" authid="jon2s7wv0" sid="jon2s7wv0" secure="true" requests="2" inactivity="30" polling="5" wait="30" hold="1" ack="9782020898" maxpause="300" ver="1.6"><stream:features><mechanisms xmlns="urn:ietf:params:xml:ns:xmpp-sasl"><mechanism>PLAIN</mechanism><mechanism >SCRAM-SHA-1</mechanism><mechanism>EXTERNAL</mechanism><mechanism>CRAM-MD5</mec h anism><mechanism>DIGEST-MD5</mechanism></mechanisms><register xmlns="http://jabber.org/features/iq-register"/><bind xmlns="urn:ietf:params:xml:ns:xmpp-bind"/><session xmlns="urn:ietf:params:xml:ns:xmpp-session"><optional/></session></stream:featu res></body>
        • stanza.io->>>  <body xmlns="http://jabber.org/protocol/httpbind" xmlns:xmpp="urn:xmpp:xbosh" rid="9782020899" sid="jon2s7wv0"><auth xmlns="urn:ietf:params:xml:ns:xmpp-sasl" mechanism="EXTERNAL"></auth></body>
        • stanza.io->>>  <body xmlns="http://jabber.org/protocol/httpbind" xmlns:xmpp="urn:xmpp:xbosh" rid="9782020900" sid="jon2s7wv0"/>
        • Openfire<<<-  <body xmlns='http://jabber.org/protocol/httpbind' ack='9782020899'><failure xmlns="urn:ietf:params:xml:ns:xmpp-sasl"><not-authorized/></failure></body>
      • websocket: I don't receive anything (plugin is installed)

       

      Do you have any idea about this problem?

       

      Best Regards,

      LeChuck

        • Re: Stanza.io with OpenFire 4.1.3
          LeChuck

          I answer my own question. Openfire offers different protocols for validation and EXTERNAL does not work fine. I have disabled this method in sasl mechanisms, you can do this adding this server property:

          sasl.mechs      PLAIN

                                   DIGEST-MD5

                                   CRAM-MD5

                                   SCRAM-SHA-1

          This solution is also applicable is you are using Kaiwa, because Kaiwa uses this stack. This work with BOSH

            • Re: Stanza.io with OpenFire 4.1.3
              Rollan

              Still getting :

              disconnected

              Client instance: { "useStreamManagement": true, "transports": [ "websocket" ], "sasl": [ "external", "scram-sha-1", "digest-md5", "plain", "anonymous" ], "jid": "test", "wsURL": "ws://localhost:7070/ws/", "server": "test", "credentials": { "password": "test" } }