AnsweredAssumed Answered

SSO - Need Help

Question asked by Cameron Hill on Mar 23, 2017
Latest reply on Aug 1, 2017 by trafsta

All:

 

I am in desperate need of getting an Openfire/Spark installation working with SSO.  Despite carefully trying to follow all of the various guides I could locate, I can't quite get it to go.  I was wondering if any one might be willing to help - I would pay you for your time.

 

I'm running Openfire 4.1.3 and Spark 2.8.3.  Everything works without SSO.  When I change the SASL.Mechs property to GSSAPI, I can no longer login in with or without SSO.  Error from the Spark log is "org.jivesoftware.smack.sasl.SASLErrorException: SASLError using GSSAPI: not-authorized".  I'm guessing it's something very simple with the keytab file, gss.conf file, or similar but this is really not my area of expertise and I need this working just as fast as humanly possible.

 

Please contact me if you would be willing to help - I would greatly appreciate it.

 

Cameron

Outcomes