AnsweredAssumed Answered

[4.2.0-alpha3] SmackException$NoResponseException while waiting for successful SASL authentication

Question asked by Jens Offenbach on Feb 19, 2016
Latest reply on Feb 22, 2016 by Flow

I am running OpenFire 4.0.1 and have tried Smack 4.2.0-alpha3. Unfortunately, there seems to be a concurrency issue during connection creation, because it is working sometimes. I have not find any hints what could be the cause. I was confronted with the problem already in version 4.2.0-alpha2. The difference is that I got the NoResponseException in this version all the time. Version 4.2.0-alpha3 seems to be a little bit better, but still has some problems. Versions 4.2.0-alpha1 and 4.1.6 are working fine. I hope that this is helpful when narrowing down the problem's source. I have increased the default packet reply timeout to maximum, but that does not make any difference. I still get the following exception:

 

org.jivesoftware.smack.SmackException$NoResponseException: No response received within reply timeout. Timeout was 9223372036854775807ms (~9223372036854775s). While waiting for successful SASL authentication

        at org.jivesoftware.smack.SmackException$NoResponseException.newWith(SmackExceptio n.java:92)

        at org.jivesoftware.smack.SASLAuthentication.authenticate(SASLAuthentication.java: 217)

        at org.jivesoftware.smack.tcp.XMPPTCPConnection.loginInternal(XMPPTCPConnection.ja va:381)

        at org.jivesoftware.smack.AbstractXMPPConnection.login(AbstractXMPPConnection.java :466)

        at org.jivesoftware.smack.AbstractXMPPConnection.login(AbstractXMPPConnection.java :423)

...

Outcomes