AnsweredAssumed Answered

IzPack 5.0.x

Question asked by veganaiZe on Sep 28, 2015

I was trying to make use of the IzPack installer with Spark 2.7.2 and IzPack 5.0.5 on Windows 8.1 (64-bit).
It didn't work.  So I hacked on the build.xml file and changed the appropriate section.
Please Consider this an informal patch (In other words: Change the related section of your build/build.xml file [line: 890+]):

 

<!-- IzPack package ========================================================================= -->

    <target name="installer.izpack" depends="exe" description="build release a izpack installer">

   <mkdir dir="${basedir}/installer/" />
    <path id="build.classpath">
        <fileset dir="${installer.izpack.dir}">
            <include name="lib/*.jar" />
        </fileset>
    </path>
   <taskdef name="IzPack"
             classpathref="build.classpath"
   classname="com.izforge.izpack.ant.IzPackTask"/>

 

   <IzPack input="${basedir}/build/installer/spark-izpack.xml" output="${basedir}/installer/spark-installer.jar"
   installerType="standard" izPackDir="${installer.izpack.dir}" basedir="${basedir}"/>

    </target>

 

 

...Then it should work!

Outcomes