AnsweredAssumed Answered

Bug with pubsub in 4.1 Alpha 5 , works good in alpha 4

Question asked by nsaoly on Nov 4, 2014
Latest reply on Nov 5, 2014 by Flow

I am creating and configuring pubsub it works well in alpha 4. however in alpha 5.
with same configure form.

 

<iq id='Bd125-20' to='pubsub.ec2-75-101-132-5.compute-1.amazonaws.com' type='set'><pubsub xmlns='http://jabber.org/protocol/pubsub'><configure><x xmlns='jabber:x:data' type='submit'><field var='pubsub#access_model' type='list-single'><value>presence</value></field><field var='pubsub#publish_model' type='list-single'><value>publishers</value></field><field var='pubsub#deliver_payloads' type='boolean'><value>0</value></field><field var='pubsub#max_items' type='text-single'><value>3</value></field><field var='pubsub#node_type' type='list-single'><value>leaf</value></field><field var='pubsub#notify_config' type='boolean'><value>1</value></field><field var='pubsub#notify_delete' type='boolean'><value>1</value></field><field var='pubsub#notify_retract' type='boolean'><value>1</value></field><field var='pubsub#persist_items' type='boolean'><value>1</value></field><field var='pubsub#presence_based_delivery' type='boolean'><value>1</value></field></x></configure><create node='griffin:profile:919715224003:data'/></pubsub></iq>

11-04 17:29:37.149  11370-15106/com.griffin D/SMACK﹕ RCV (0): <iq from='pubsub.ec2-75-101-132-5.compute-1.amazonaws.com' to='919715224003@ec2-75-101-132-5.compute-1.amazonaws.com/F26A2705' type='error' id='Bd125-20'><pubsub xmlns='http://jabber.org/protocol/pubsub'><configure><x xmlns='jabber:x:data' type='submit'><field var='pubsub#access_model' type='list-single'><value>presence</value></field><field var='pubsub#publish_model' type='list-single'><value>publishers</value></field><field var='pubsub#deliver_payloads' type='boolean'><value>0</value></field><field var='pubsub#max_items' type='text-single'><value>3</value></field><field var='pubsub#node_type' type='list-single'><value>leaf</value></field><field var='pubsub#notify_config' type='boolean'><value>1</value></field><field var='pubsub#notify_delete' type='boolean'><value>1</value></field><field var='pubsub#notify_retract' type='boolean'><value>1</value></field><field var='pubsub#persist_items' type='boolean'><value>1</value></field><field var='pubsub#presence_based_delivery' type='boolean'><value>1</value></field></x></configure><create node='griffin:profile:919715224003:data'/></pubsub><error code='501' type='cancel'>
<feature-not-implemented xmlns='urn:ietf:params:xml:ns:xmpp-stanzas'/></error></iq>
11-04 17:29:39.324  11370-11370/com.griffin W/System.err﹕ feature-not-implemented
11-04 17:29:39.329  11370-11370/com.griffin W/System.err﹕ at org.jivesoftware.smack.PacketCollector.nextResultOrThrow(PacketCollector.java:197)
11-04 17:29:39.329  11370-11370/com.griffin W/System.err﹕ at org.jivesoftware.smack.PacketCollector.nextResultOrThrow(PacketCollector.java:178)
11-04 17:29:39.329  11370-11370/com.griffin W/System.err﹕ at org.jivesoftware.smackx.pubsub.PubSubManager.sendPubsubPacket(PubSubManager.java:316)

 

in alpha 4 it send

<create node='griffin:profile:jeettest:data'/><configure><x xmlns='jabber:x:data' type='submit'>

<field></field>

</x></configure>

</pubsub></iq>">>

 

and in alpha5 it send

<configure><x xmlns='jabber:x:data' type='submit'>

<field></field>

</x></configure>

<create node='griffin:profile:jeettest:data'/>

</pubsub></iq>">>

 

 

create node tags are changed causing to get feature not implemented error.

Outcomes