3 Replies Latest reply on Oct 23, 2014 7:49 PM by David Truesdale

    I understand the Frustration with lack of documentation............

    David Truesdale

      I have done 2 fresh installs. Had one working flawlessly, then all the sudden it won't videobridge. No changes nothing. I did another and can not get it to bridge no matter what I do. I have done IT since 1992. I have used Linux since 1997.

       

      I think the documentation is lacking in the areas of what is required and what specific things need to be set depending on your setup. Such as Firewall and NAT requirements. I found it to be using ports well outside the range of what was given. Setup 100000:20000 TCP & UDP and then watched it use ports in the 30000 range.

       

      Also What plugins are required and what plugins are not? Better yet the Openfire/jitsi videobridge everyone passes you off too, to test your client, post it's setup. These things would be helpful.

       

      I see community support but I have yet to see common issues solved and documented correctly for the rest of the community to be able to learn from and even add too.

       

      Yes I am using the latest of both openfire 3.9.3 and jitsi videobridge 1.3.1.

       

      I have read every post on this and all have common issues but no resolution.

       

      Is websockets still required?

       

      Just got these errors:

       

      2014.10.23 19:25:46 org.jivesoftware.openfire.session.LocalOutgoingServerSession - Error trying to connect to remote server: jitsi-videobridge.wiki.veriah.info(DNS lookup: jitsi-videobridge.wiki.veriah.info:5269): java.net.SocketTimeoutException: connect timed out

      2014.10.23 19:25:46 org.jivesoftware.openfire.IQRouter - Error or result packet could not be delivered <iq type="error" id="1:sendIQ" to="2e891d4a@wiki.veriah.info/2e891d4a" from="jitsi-videobridge.wiki.veriah.info"><conference xmlns="http://jitsi.org/protocol/colibri"><content name="audio"><channel initiator="true" expire="15" endpoint="fix_me_focus_endpoint"/><channel initiator="true" expire="15" endpoint="4c6b808e"/></content><content name="video"><channel initiator="true" expire="15" endpoint="fix_me_focus_endpoint"/><channel initiator="true" expire="15" endpoint="4c6b808e"/></content></conference><error code="404" type="cancel"><remote-server-not-found xmlns="urn:ietf:params:xml:ns:xmpp-stanzas"/></error></iq>

      2014.10.23 19:25:56 org.jivesoftware.openfire.container.PluginClassLoader - Failed to cache plugin JAR file: jar:file:/opt/openfire/plugins/clustering/lib/plugin-clustering-jspc.jar!/

      2014.10.23 19:26:16 org.jivesoftware.openfire.container.PluginClassLoader - Failed to cache plugin JAR file: jar:file:/opt/openfire/plugins/clustering/lib/plugin-clustering-jspc.jar!/

      2014.10.23 19:26:36 org.jivesoftware.openfire.container.PluginClassLoader - Failed to cache plugin JAR file: jar:file:/opt/openfire/plugins/clustering/lib/plugin-clustering-jspc.jar!/

      2014.10.23 19:26:56 org.jivesoftware.openfire.container.PluginClassLoader - Failed to cache plugin JAR file: jar:file:/opt/openfire/plugins/clustering/lib/plugin-clustering-jspc.jar!/

      2014.10.23 19:27:16 org.jivesoftware.openfire.container.PluginClassLoader - Failed to cache plugin JAR file: jar:file:/opt/openfire/plugins/clustering/lib/plugin-clustering-jspc.jar!/

      2014.10.23 19:27:36 org.jivesoftware.openfire.container.PluginClassLoader - Failed to cache plugin JAR file: jar:file:/opt/openfire/plugins/clustering/lib/plugin-clustering-jspc.jar!/

      2014.10.23 19:27:54 org.jivesoftware.openfire.container.PluginClassLoader - Failed to cache plugin JAR file: jar:file:/opt/openfire/plugins/clustering/lib/plugin-clustering-jspc.jar!/

       

      It worked and all the sudden it is not.

       

      Message was edited by: David Truesdale