AnsweredAssumed Answered

CentOS RPM upgrade to 3.9.2 broke LDAP Auth

Question asked by Parabola1337 on May 1, 2014
Latest reply on May 6, 2014 by Arthur Pemberton

I upgraded to 3.9.2 this morning with the official RPM, and when openfire started up users were no longer able to authenticate, nor could i login to the admin panel.

 

I'm not seeing anything in the error log or warning log, info log has a slew of entries of users clients attempting to authenticate

 

2014.05.01 09:35:13 org.jivesoftware.openfire.net.SASLAuthentication - User Login Failed. PLAIN authentication failed for:

 

Steps used to update.

1.) CentOS 6.5, used the RPM (rpm -Uvh fileName.rpm)

2.) ensured saslauthd and openfire were running

3.) attempted to login

 

Steps used to try and resolve the issue (not in any particular order, didnt document the order!

1.) restarting services (saslauthd and openfire)

2.) verified permissions on all files and directories in /opt/openfire

3.) moved all plugins except admin out of plugins directory

4.) tried replacing the openxml.conf file with a backup

5.) tried replacing the embedded-db with a backup

 

At this time due to needing this service running have restored a snapshot, but am willing to do testing.

 

-Chris


Outcomes