AnsweredAssumed Answered

Adding phone server

Question asked by prashanthf007 on Nov 13, 2013

Hello everyone! I've been trying to integrate the asterisk with openfire and I;ev reached the point after installing the Asterisk-IM plugin and adding the phone server. I've added the server and got it listed,but now it doesn't seem to be active as there is no green dot, instead its a grey dot.

 

These are my configuration details:

 

Openfire server: running on Windows server 2008, Domain=tnkochi.com, ip address:192.168.0.1

Elastix server: running on Linux server(This machine is part of the same network, but NOT a part of my domain tnkochi.com), ip address:192.168.0.30, Iptables on this machine are turned off.

 

This is my /etc/amportal.conf

 

AMPDBHOST=localhost

AMPDBENGINE=mysql

AMPDBUSER=asteriskuser

AMPDBPASS=fq!rs!cd50

AMPENGINE=asterisk

AMPMGRUSER=admin

AMPMGRPASS=fq!rs!cd50

 

This is the configuration of the server that I've added in the Asterisk-IM

 

name:localhost(I've also tried 'localhost.localdomain' which is the hostname of that machine)

address:192.168.0.30  

port:5038

user:admin

password:fq!rs!cd50

 

Should this linux machine be added to my Windows domain to establish a connection?

 

 

 

Please help me out here, Thanks in advance.

Outcomes