AnsweredAssumed Answered

Drop Java 5/6 support in Openfire

Question asked by wroot Champion on Aug 13, 2013
Latest reply on Feb 16, 2014 by Guus der Kinderen

So, i wanted to discuss this with the community and developers. maybe it is time to drop Java 5/6 support from Openfire? Say for 4.0.0 version? Now some developers has to do this OF-691 to comply with ages old Java 5. Java 6 is also long time EOL. I have already filed same for Spark - SPARK-1545. Old java makes old bugs and issues come up again. Old version would still have old java support, so i see no point in supporting that for newer versions. Unless it is too much work to drop it.

Outcomes