AnsweredAssumed Answered

How to use different log4j version in plugin

Question asked by adb on Jul 1, 2011
Latest reply on Aug 16, 2011 by adb

My plugin has a depency on a jar file that depends on log4j 1.3.  Even if I include the log4j 1.3 jar file in my plugin/lib directory I still get undefined method Logger.isTraceEnabled

 

Is there any way to separate out a plugin so that its classloader will find classes locally before delegating upwards.  I think it uses the JiveClassLoader, but that will just tag the jar/zip files from the lib directory onto the existing path and not allow the plugin classes to override those in the core lib directory.

Outcomes