AnsweredAssumed Answered

RED5 not loading in the Admin Console

Question asked by wannabee on Jun 2, 2011
Latest reply on May 22, 2012 by Dele Olajide

Hi there,

 

First of all thanks to ignite and Jive members for this awesome tool!

 

I have Openfire 3.7 server with Spark 2.6 as a client running.

 

I wanted to get Red5 installed and performed the following step:

 

 

 

1) Downloaded the plugin(Red5.war) from the beta plugins link - Admin Console doesnt recognize it

2) Stop the openfire service tried again... still nothing

3) Downloded a previous version and tried - still no luck

4) I even tried changing the Http-Bind port but ofcourse no luck since RED5 is not loading

 

The plugin is not loading in the Admin Console no matter what I do. Do i need to reinstall Openfire?

 

Here is the log:

 

 

at java.lang.ClassLoader.loadClass(Unknown Source)               
                     at java.net.URLClassLoader.findClass(Unknown Source)               
                     at java.security.AccessController.doPrivileged(Native Method)               
                     at java.net.URLClassLoader$1.run(Unknown Source)               
                Caused by: java.lang.ClassNotFoundException: org.mortbay.jetty.HandlerContainer               
                     at java.lang.Thread.run(Unknown Source)               
                     at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)               
                     at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)               
                     at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(Unknow n Source)               
                     at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.runPeriodi c(Unknown Source)               
                     at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$101 (Unknown Source)               
                     at java.util.concurrent.FutureTask.runAndReset(Unknown Source)               
                     at java.util.concurrent.FutureTask$Sync.innerRunAndReset(Unknown Source)               
                     at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)               
                at org.jivesoftware.openfire.container.PluginManager$PluginMonitor.run(PluginManag er.java:1067)               
                at org.jivesoftware.openfire.container.PluginManager.access$300(PluginManager.java :80)               
                at org.jivesoftware.openfire.container.PluginManager.loadPlugin(PluginManager.java :420)               
                     at java.lang.Class.newInstance(Unknown Source)               
                     at java.lang.Class.newInstance0(Unknown Source)               
                     at java.lang.Class.getConstructor0(Unknown Source)               
                     at java.lang.Class.privateGetDeclaredConstructors(Unknown Source)               
                     at java.lang.Class.getDeclaredConstructors0(Native Method)               
                java.lang.NoClassDefFoundError: org/mortbay/jetty/HandlerContainer               
                2011.06.02 13:14:09 Error loading plugin: J:\Program Files\Openfire1\plugins\red5               

 

 

Thanks in advance.

Outcomes