AnsweredAssumed Answered

OpenFire and Red5.war Installation

Question asked by AjsAjs on Oct 1, 2009
Latest reply on Oct 6, 2009 by AjsAjs

Hopefully someone can help with a question regarding OpenFire and the Red5 plug-in.

 

The Red5 plugin readme (http://www.igniterealtime.org/community/docs/DOC-1518) says:

 

You will need Openfire version 3.5.0 and above. Java 1.6 is required.

 

Installation

Enable HTTP_BIND on Openfire (if disabled) and note the HTTP port.

Copy the red5.war file to the Openfire_HOME/plugins directory.

Go to the page http://your_server:your_http_bind_port/red5/index.html on your server to use the red5 flash web applications in your own client applications.

 

Our OpenFire installation is:

 

Windows 2K server.

Version: Openfire 3.6.4

Java Version: 1.6.0_03 Sun Microsystems Inc. -- Java HotSpot(TM) Server VM

Appserver: jetty-6.1.x

 

Red5War_0.8.0.zip was obtained from http://code.google.com/p/red5/downloads/list, unzipped and root.war renamed to red5.war.

 

After following the installation instructions OpenFire does not pick the red5.war file and does not create the red5 folder.

 

Are we missing the obvious ?

Outcomes