AnsweredAssumed Answered

Problem building Sparkweb by the first time

Question asked by danipellex on Mar 19, 2009
Latest reply on Oct 5, 2010 by Kazzin

Hi all,

i am been working with spark for some months, and now its time to sparkweb. this is a really good product. but i am just a novice with no experience in flash. After reading about flash, flex, making some hello world tutorial for eclipse with flex builder, and reading all articles i found about "how to start with sparweb", like http://www.igniterealtime.org/community/docs/DOC-1400  , i had problems:

 

0) I work in windows xp

1) I installed Adobe Flex Builder 3, to compile flash sources

2) I download the full sparkweb sources from repository

by doing svn co http://svn.igniterealtime.org/svn/repos/sparkweb/trunk/

3) I changed <sparkweb-root>/build/build.xml <property name="FLEX_HOME" value="..."/>

to my installation path <property name="FLEX_HOME" value="D:/Program Files/Adobe/Flex Builder 3 Plug-in/sdks/3.2.0"/>

4) I run ant 1.7 over <sparkweb-root>/build/build.xml and i get many many errors:

 

 

 

Buildfile: D:\javaprojects\Sparkweb\build\build.xml
-clean-deploy-root:
    [delete] Deleting directory D:\javaprojects\Sparkweb\target\sparkweb
-sparkweb-html-wrapper:
     [mkdir] Created dir: D:\javaprojects\Sparkweb\target\sparkweb
      [copy] Copying 4 files to D:\javaprojects\Sparkweb\target\sparkweb
      [copy] Copying 1 file to D:\javaprojects\Sparkweb\target\sparkweb
sparkweb:
     [mxmlc] Loading configuration file D:\Program Files\Adobe\Flex Builder 3 Plug-in\sdks\3.2.0\frameworks\flex-config.xml
     [mxmlc] D:\javaprojects\Sparkweb\SparkWebCommonComponents\com\jivesoftware\spark\MUCRoo mListItemRenderer.mxml(50): Error: unable to resolve '/assets/images/bookmark.png' for transcoding
     [mxmlc]         [Embed(source="/assets/images/bookmark.png")]
     [mxmlc] D:\javaprojects\Sparkweb\SparkWebCommonComponents\com\jivesoftware\spark\MUCRoo mListItemRenderer.mxml(50): Error: Unable to transcode /assets/images/bookmark.png.
     [mxmlc]         [Embed(source="/assets/images/bookmark.png")]

...

 

 

5) I tried by adding classpath with assets dir to mxmlc target which fails first, like shown next, but nothing

classpath="${basedir}"  in  <mxmlc ... >

 

 

I have searched with no luck. Any help will be appreciated.

 

dani

Outcomes