AnsweredAssumed Answered

A few questions: Red5 SparkWeb configuration / Fastpath

Question asked by ravil on Feb 25, 2009
Latest reply on Mar 27, 2009 by nsn_r

Hi everyone,

I have a difficulty configuring red5's sparkweb. It does not connect to my openfire server (though the standard sparkweb works fine). When I enter my userame, and click on login, the login button just becomes gray and nothing happens.

I am using red5 0.1.10 plugin and openfire 3.6.3.

 

Connection config of sparkweb:

   function jive_sparkweb_getConfig()
    {

 

        var username = getPageParameter('username', '');
        var password = getPageParameter('password', '');
        var autologin = getPageParameter('autologin', 'false');
        var webapp = getPageParameter('webapp', 'red5');
        var conn = getPageParameter('conn', 'socket');            // socket, http or rtmp (using xmppurl below)
        var tls = getPageParameter('tls', 'true');                // socket, use TLS or not

 

        return {

 

            httpLabel: "Ignite",
            httpURL: "http://www.igniterealtime.org",
            username: username,
            password: password,
            server: "regmac04.uwaterloo.ca",
            port: conn == "socket" ? 5222 : window.location.port,
            red5url: "rtmp:/sip",
            xmppurl: "rtmpt::8000/xmpp",
            webapp: webapp,
            connectionType: conn,
            connectionTLS: tls,
            policyFileURL: "xmlsocket://" + window.location.hostname + ":5222",
            webcamAvatar: "false",
            visualPresence: 120,
            historyChats: 2,
            autologin: "false"
        };
    }

 

I have port 7070 enabled in openfire... I tried to change the port to 7070 in the config for sparkweb (instead of 5222, as above), but it didn't work.

Please help me to figure out what could be wrong with my connection settings. I know there are simillar posts on the forum, but they did not really help me to figure out what should I do...

 

Any help would be appreciated! Thanks in advance!

 

Also, please tell me if red5's sparkweb will also allow me to work with fastpath through the web browser? I tried one red5 sparkweb client available on the internet to connect to my openfire server, but unfortunately it didn't really work with fastpath...

Outcomes