AnsweredAssumed Answered

AIM outward presence - Show's openfire users offline until message sent

Question asked by rculpepper on Oct 31, 2008
Latest reply on Nov 6, 2008 by rculpepper

Using openfire 3.5.2, IM gateway 1.2.3, on Solaris

 

I have a set of users that use the AIM gateway. It seems to work except every once in a while there are some presence issues that cause a lot of problems.

 

They are pretty intermittent, and I haven't found anything conclusive in the log files.

 

What is happening is this - an AIM transport user will appear offline to the outside AIM world, even though he is logged in and can see everyone else's presence just fine. Once he messages someone, his presence corrects itself.

 

I checked the log files and all I could find for the user is the following in error.log

 

<iq id="jcl_109" type="set" from="user@my.domain.whatever/resource">
<iq id="jcl_109" type="set" from="user@my.domain.whatever/resource">
<iq id="jcl_113" type="set" from="user@my.domain.whatever/resource">
<iq id="jcl_113" type="set" from="user@my.domain.whatever/resource">
<iq id="jcl_129" type="set" from="user@my.domain.whatever/resource">
<iq id="jcl_129" type="set" from="user@my.domain.whatever/resource">
<iq id="jcl_127" type="set" from="user@my.domain.whatever/resource">
<iq id="jcl_127" type="set" from="user@my.domain.whatever/resource">
<iq id="jcl_175" type="set" from="user@my.domain.whatever/resource">
<iq id="jcl_175" type="set" from="user@my.domain.whatever/resource">

 

 

Is this a known issue fixed in the next version of openfire/IM server? I've been putting off the upgrade due to other issues posted in the openfire support forum that I am afraid of, and I have heard of additional issues with the IM gateway plugin as well.

 

Also, what are these entries to the error log indicative of?

Outcomes