AnsweredAssumed Answered

Unable to playback video messages

Question asked by hollywood69 on Sep 17, 2008
Latest reply on Sep 23, 2008 by Dele Olajide

Apologies for the numerous posts - can you tell that I've started in earnest on Red5 with Spark this week?

 

Spark 2.5.8 on Windows XP, Openfire 3.5.2 (Red Hat), Red5 plugin v0.0.27

 

I have the audio / video rosters in Spark working and people can see each others webcams etc. Where I'm having problems is the playback of video messages. I can record ok (seemingly) and .FLV files are written to /opt/openfire/plugins/red5/streams. However the recipient doesn't get a notification and when they go to playback any messages, there is nothing showing as waiting. The following is wriiten to Openfire's Info log -

 

2008.09.17 11:28:16 libraryDirectory = /opt/openfire/plugins/red5/streams/                 
2008.09.17 11:28:16 unexpected sample                 
2008.09.17 11:29:40 libraryDirectory = /opt/openfire/plugins/red5/streams/                 
2008.09.17 11:30:04 libraryDirectory = /opt/openfire/plugins/red5/streams/                 
2008.09.17 11:30:04 ignoring kate_murphy$nick_chaplin$Wed_Sep_17_11_28_42_GMT+0100_2008_300886 for nick_chaplin                 
2008.09.17 11:30:04 unexpected sample                 
2008.09.17 13:06:14 libraryDirectory = /opt/openfire/plugins/red5/streams/                 
2008.09.17 13:06:14 ignoring kate_murphy$nick_chaplin$Wed_Sep_17_11_28_42_GMT+0100_2008_300886 for nick_chaplin                 
2008.09.17 13:06:14 unexpected sample                 
2008.09.17 13:16:21 libraryDirectory = /opt/openfire/plugins/red5/streams/                 
2008.09.17 13:16:21 unexpected sample                 
2008.09.17 13:17:19 libraryDirectory = /opt/openfire/plugins/red5/streams/                 
2008.09.17 13:17:19 unexpected sample                 
2008.09.17 13:31:35 libraryDirectory = /opt/openfire/plugins/red5/streams/                 
2008.09.17 13:33:08 libraryDirectory = /opt/openfire/plugins/red5/streams/                 
2008.09.17 13:33:08 ignoring kate_murphy$nick_chaplin$Wed_Sep_17_13_30_31_GMT+0100_2008_187651 for nick_chaplin                 
2008.09.17 13:33:08 ignoring kate_murphy$nick_chaplin$Wed_Sep_17_11_28_42_GMT+0100_2008_300886 for nick_chaplin                 
2008.09.17 13:33:08 unexpected sample                 
2008.09.17 13:43:13 libraryDirectory = /opt/openfire/plugins/red5/streams/                 
2008.09.17 13:43:13 ignoring kate_murphy$nick_chaplin$Wed_Sep_17_13_30_31_GMT+0100_2008_187651 for nick_chaplin                 
2008.09.17 13:43:13 ignoring kate_murphy$nick_chaplin$Wed_Sep_17_11_28_42_GMT+0100_2008_300886 for nick_chaplin                 
2008.09.17 13:43:13 unexpected sample                 
2008.09.17 13:53:09 libraryDirectory = /opt/openfire/plugins/red5/streams/                 
2008.09.17 13:53:09 ignoring kate_murphy$nick_chaplin$Wed_Sep_17_13_30_31_GMT+0100_2008_187651 for nick_chaplin                 
2008.09.17 13:53:09 ignoring kate_murphy$nick_chaplin$Wed_Sep_17_11_28_42_GMT+0100_2008_300886 for nick_chaplin                 
2008.09.17 13:53:09 unexpected sample                 
2008.09.17 13:54:52 libraryDirectory = /opt/openfire/plugins/red5/streams/

 

In this case I (nick_chaplin) was recording a message for kate_murphy. I have also used the test application and again it allows me to record but when i try and test playback, nothing happens - Firefox just sits there connecting to localhost (?) with a blank screen...

 

Any pointers as to where I can start to look to solve?

 

Cheers, Nick

Outcomes