weitsecR

Windows Install buggy (2.5.8 & 2.6.0beta)

Discussion created by weitsecR on Jun 20, 2008
Latest reply on Dec 17, 2009 by Mahhoura

Hi,

 

after a fresh install of Spark 2.5.8 it was impossible to voice chat. Reconnecting mike, rebooting, reinstalling, nothing helped.

Starting via startup.bat there was a

  java.lang.NoClassDefFoundError: mil/jfcom/cie/media/session/MediaSessionListener

 

Searching for the appropriate class we found the class in the Speex.jar inside %SPARK_HOME%\plugins\jingle.jar in the lib directory.

Moving that to %SPARK_HOME%\jre\lib\ext solved the issue.

 

The problem seems to be in the 2.6.0 beta1 installer as well, but not in the Mac version. Interesting enough two colleagues had no problem: They had installed an older version of Spark and installing the new one in the same directory.

 

And two other issues concerning the buggy windows install: The file bin/startup.bat is unix-like with slashes and doesn't explicitly use the co-installed JRE (java.exe).

 

We'd be happy to see this solved as Spark seems great.

 

weitsecR

Outcomes