agustus

no dial button in spark

Discussion created by agustus on Aug 17, 2006
Latest reply on Aug 29, 2006 by vinicia

Hi,

I will make this problem very clear. I successfully installed wildfire and asterisk in my lan. This is my lan:

1. Server ( this is where I installed wildfire and asterisk ): Linux

2. Client A ( this is where I installed spark and sip software ): Windows XP

3  Client B ( this is where I installed spark and sip software ): Windows XP

 

Spark in Client A can communicate ( text messaging, send file ) to Client B. Sip software ( something like ekiga, xlite, etc ) in Client A can phone ( even video chat ) with sip software in Client B.

 

I am strugling to intregate both of them. Here''s what I do:

Installing asterisk-im.jar. Download from here ( http://couplet.be/temp/status_fix/asterisk-im.jar ). If I use asterisk-im from official server, when I click "phone mappings" in asterisk-im tabs in wildfire admin console, I get blank page. The version of the plugin is 1.1.1.  I get that link from this thread ( http://www.jivesoftware.org/community/thread.jspa?threadID=20813&start=0&tstart= 0 ).

 

This is my asterisk configuration in Server:

/etc/asterisk/sip.conf

context=default

srvlookup=yes

videosupport=yes                ; Turn on support for SIP video

realm=hulahula

;recordhistory=yes              ; Record SIP history by default

                                ; (see sip history / sip no history)

 

disallow=all                    ; First disallow all codecs

allow=ulaw                      ; Allow codecs in order of preference

allow=alaw

allow=speex

allow=gsm

allow=h261

allow=h263

allow=h263p

type=friend

secret=welcome

qualify=yes      ; Qualify peer is no more than 2000 ms away

nat=no           ; This phone is not natted

host=dynamic     ; This device registers with us

canreinvite=no   ; Asterisk by default tries to redirect

context=internal ; the internal context controls what we can do

type=friend

secret=welcome

qualify=yes      ; Qualify peer is no more than 2000 ms away

nat=no           ; This phone is not natted

host=dynamic     ; This device registers with us

canreinvite=no   ; Asterisk by default tries to redirect

context=internal ; the internal context controls what we can do

 

/etc/asterisk/extensions.conf

exten => 100,1,Dial(SIP/john)

exten => 101,1,Dial(SIP/mery)

exten => 611,1,Echo( )

 

/etc/asterisk/manager.conf

enabled = yes

port = 5038

bindaddr = 127.0.0.1

 

; No access is allowed by default.

; To set a password, create a file in /etc/asterisk/manager.d

; use creative permission games to allow other serivces to create their own

; files

#include "manager.d/*.conf"

 

secret=mysecret

read=system,call,log,verbose,command,agent,user

write=system,call,log,verbose,command,agent,user

 

This is my configuration of asterisk-im from wildfire admin console:

General configuration:

enabled: yes

server: hulahula

port: 5038

username: mark

password: mysecret

drop-down device selection: yes

asterisk context: internal

default caller id: blank or empty

dial command variables: empty or blank

 

Note: hulahula is Server hotsname ( the output of ''hostname'' in Server console ).

 

Phone mappings:

username          device       extensions       caller id

akbar                sip/john      100                 akbar

alex                  sip/mery     101                

 

Note: akbar and alex is my wildfire user. I manage successfully make text messaging between these usernames.

 

The wildfire server configuration:

Server name: hulahula

 

But in spark client ( in client A or client B ) there is no dial button or any button to make phone functions. Spark version is 2.0.0.1. Wildfire version is 3.0.1.

 

Note: This is what I put in login dialog of spark to connect to server

username: akbar or alex

password: ******

server: the ip address of Server ( 192.168.1.115 )

 

I have read documentations and search forums. Somebody said this is full qualified domain names ( fqdn ) issue but I don''t understand. This is only local lan. How do I find fqdn of my Server anyway if this is that issue?

 

Message was edited by: agustus

Outcomes