apyles

RING event not being generated

Discussion created by apyles on Jul 28, 2006
Latest reply on Sep 20, 2006 by statik213

Hi,

 

I''ve got asterisk 1.0.9

Wildfire 3.0.1 plus asterisk-im 1.1.1

 

I have 2 sip extensions on my asterisk server: 149, 150

I have these 2 extensions registered and can call between them.

 

I have the following mapping done on the phone mappings settings:

 

150 SIP/andy 150 andy <5555551234> Edit Delete

149 SIP/prasanna 149 prasanna <5555554321> Edit Delete

 

asterisk sip.conf has:

 

callerid=prasanna <510-555-4321>

type=friend

context=default

allow=all

secret=password

host=dynamic

 

callerid=andy <510-555-1234>

type=friend

context=default

allow=all

secret=password

host=dynamic

 

....

I then performed the following test:

1.) ensure that JABBER accounts 149 / 150 are signed in.

2.) make sure that both sip accounts are registered with softphones

3.) make a call from andy to prasanna (+sip)+.

4.) I expect to see a RING event sent to the JABBER client - 149. ( but it doesn''t show up) *

5.) Once I answer the phone, a ON_THE_PHONE event is sent to the 150. But the 149 doesn''t get the ringing.

 

 

NOTES:

 

  • I expect to see an XMPP message to extension 149 here something like:

 

<phone-event status="RING" device="SIP/prasanna" id="a7f2ag">

<callerID>5105551234</callerID>

</phone-event>

 

~~~~~

Further debug information. After putting a sniffer on the Asterisk Manager interface. I see that it sends the RINGING message to the

server. Any idea whats going on here?

 

Here''s the sniffer trace from asterisk manager:

 

#

 

Event: Newchannel.

 

 

 

#

Channel: SIP/andy-794f.

State: Ring.

CallerID: andy <510-555-1234>.

Uniqueid: 1154106744.129.

 

 

 

#

 

 

 

##

Event: Newexten.

 

 

 

###

Channel: SIP/andy-794f.

Context: default.

Extension: 149.

Priority: 1.

Application: Macro.

AppData: stdexten|prasanna|SIP/prasanna.

Uniqueid: 1154106744.129.

 

 

Outcomes