AnsweredAssumed Answered

item-not-found(404)

Question asked by Gigi on Jan 30, 2017

I installed openfire (4.1.1) with ofmeet plugin (0.3.28)  to create a video meeting through rocket-chat.

 

All is working, in rocket-chat i able to start a new video meeting, but sometimes openfire falls in error and in the error.log i see this:

 

 

2017.01.30 08:40:03 org.jitsi.jicofo.JitsiMeetConference - net.java.sip.communicator.service.protocol.OperationFailedException: Failed to join the room

 

net.java.sip.communicator.service.protocol.OperationFailedException: Failed to join the room

 

    at org.jitsi.impl.protocol.xmpp.ChatRoomImpl.joinAs(ChatRoomImpl.java:200)

 

    at org.jitsi.impl.protocol.xmpp.ChatRoomImpl.joinAs(ChatRoomImpl.java:290)

 

    at org.jitsi.impl.protocol.xmpp.ChatRoomImpl.join(ChatRoomImpl.java:249)

 

    at org.jitsi.jicofo.JitsiMeetConference.joinTheRoom(JitsiMeetConference.java:342)

 

    at org.jitsi.jicofo.JitsiMeetConference.maybeJoinTheRoom(JitsiMeetConference.java: 324)

 

    at org.jitsi.jicofo.JitsiMeetConference.registrationStateChanged(JitsiMeetConferen ce.java:1119)

 

    at org.jitsi.jicofo.ProtocolProviderHandler.registrationStateChanged(ProtocolProvi derHandler.java:123)

 

    at net.java.sip.communicator.service.protocol.AbstractProtocolProviderService.fire RegistrationStateChanged(AbstractProtocolProviderService.java:176)

 

    at net.java.sip.communicator.service.protocol.AbstractProtocolProviderService.fire RegistrationStateChanged(AbstractProtocolProviderService.java:130)

 

    at org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.register(XmppProtocolProvider .java:171)

 

    at org.jitsi.jicofo.util.RegisterThread.run(RegisterThread.java:38)

 

Caused by: item-not-found(404)

 

    at org.jivesoftware.smackx.muc.MultiUserChat.create(MultiUserChat.java:360)

 

    at org.jitsi.impl.protocol.xmpp.ChatRoomImpl.joinAs(ChatRoomImpl.java:152)

 

    ... 10 more

 

2017.01.30 08:40:03 org.jitsi.impl.protocol.xmpp.OperationSetJingleImpl - Received an error: code=404 message=null

 

2017.01.30 08:40:03 org.jitsi.impl.protocol.xmpp.OperationSetJingleImpl - Received an error: code=404 message=null

 

2017.01.30 08:40:03 net.java.sip.communicator.util.UtilActivator - An uncaught exception occurred in thread=Thread[Thread-156,5,main] and message was: null

 

java.lang.NullPointerException

 

    at org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.register(XmppProtocolProvider .java:178)

 

    at org.jitsi.jicofo.util.RegisterThread.run(RegisterThread.java:38)

 

 

Is there a fix or a specific setting to avoid this random error (It happened in a week due Times)?

 

Thanks.

 

Gigi

Outcomes