Openfire .tar.gz + Eclipse 3.1 Installation Guide

Document created by LG Champion on Aug 17, 2007
Version 1Show Document
  • View in full screen mode

The following instructions were updated in May 2007 for Openfire.

 

Setup Openfire

 

Install jdk-1_5_0_11-windows-i586-p.exe (or just copy the files to

%programfiles%\Java so you're registry is not modified)

Extract eclipse-SDK-3.1.2-win32.zip to C:\Tools\

Start C:\Tools\eclipse\eclipse.exe and set

Workspace to C:\ws\eclipse\workspace\

If start fails because no javaw.exe is found add

%programfiles%\Java\jdk1.5.0_11\bin to the PATH

variable manually and start it

Close the Welcome screen

Menu Window, Preferences; Java, Compiler:

"Compiler Compliance Level:" 5.0

Exit Eclipse

Extract openfire_src_3_3_1.jar to C:\ws\eclipse\workspace\

Start Eclipse

Select File, New, Project;

Java Project Next;

Project Name "openfire_src" (JDK Compliance and

Projct layout will get disabled) Next;

Finish

Menu Window, Show Wiew, Ant;

Right click in "Ant", "Add Buildfiles"

Select openfire_src\build\build.xml

Double click "all" ... and wait to complete the build

 

Help Eclipse to find the right build path

 

Menu File, Properties: Configure Build Path: Libraries: Add External JARs: Add all files you find in openfire_src\target\openfire\lib

That's really a little bit crazy but with this Eclipse version it seems to be the only possible solution.

 

Debug Openfire 3.3.1

 

Menu Run, Debug ...: New

 

Main

 

Project: openfire_src

Main class: org.jivesoftware.openfire.starter.ServerStarter

 

Arguments

 

Program Arguments:

VM Arguments:

\-DopenfireHome="$\{workspace_loc:openfire_src\}/target/openfire"

Working Directory

\[x\] Use default working directory

Workspace: $\{workspace_loc:openfire_src\}

 

Apply

Debug

Attachments

    Outcomes